Back to overview
Maintenance
Backend update
Oct 18 at 11:30pm EDT
–
Oct 19 at 05:30am EDT
Affected services
Website
Resolved
Oct 19 at 06:03am EDT
Backend update is complete.
Thank you for your patience.
Affected services
Updated
Oct 19 at 04:44am EDT
Extending maintenance window by 1 hour
Affected services
Created
Oct 18 at 11:30pm EDT
We will be performing a backend update on our systems, our service may be unavailable or operating slowly during these times.
Affected services